ViewVC Help
View File | Revision Log | Show Annotations | Revision Graph | Root Listing
root/cebix/BasiliskII/BasiliskII.spec
Revision: 1.18
Committed: 2001-02-02T20:52:56Z (23 years, 2 months ago) by cebix
Branch: MAIN
CVS Tags: snapshot-17022001, snapshot-29052001
Changes since 1.17: +1 -1 lines
Log Message:
- bumped version number to 0.9
- updated copyright dates

File Contents

# User Rev Content
1 cebix 1.13 %define name BasiliskII
2 cebix 1.18 %define version 0.9
3 cebix 1.13 %define release 1
4    
5 cebix 1.15 Summary: 68k Macintosh emulator
6 cebix 1.13 Name: %{name}
7     Version: %{version}
8     Release: %{release}
9 cebix 1.1 Copyright: GPL
10 cebix 1.10 Group: Applications/Emulators
11 cebix 1.17 Source: %{name}_src_08122000.tar.gz
12 cebix 1.10 URL: http://www.uni-mainz.de/~bauec002/B2Main.html
13 cebix 1.13 BuildRoot: %{_tmppath}/%{name}-root
14 cebix 1.16
15     # While the data file path (/usr/share/BasiliskII) is compiled into the
16     # executable, the data files are not required for operation and their location
17     # can be overridden with prefs items, so I consider this package to be
18     # relocatable.
19 cebix 1.13 Prefix: %{_prefix}
20 cebix 1.1
21     %description
22 cebix 1.15 Basilisk II is an Open Source 68k Macintosh emulator. That is, it enables
23     you to run 68k MacOS software on you computer, even if you are using a
24     different operating system. However, you still need a copy of MacOS and
25     a Macintosh ROM image to use Basilisk II.
26 cebix 1.1
27     Some features of Basilisk II:
28     - Emulates either a Mac Classic (which runs MacOS 0.x thru 7.5)
29     or a Mac II series machine (which runs MacOS 7.x, 8.0 and 8.1),
30     depending on the ROM being used
31     - Color video display
32     - CD quality sound output
33     - Floppy disk driver (only 1.44MB disks supported)
34     - Driver for HFS partitions and hardfiles
35     - CD-ROM driver with basic audio functions
36 cebix 1.8 - Easy file exchange with the host OS via a "Host Directory Tree" icon
37     on the Mac desktop
38 cebix 1.1 - Ethernet driver
39     - Serial drivers
40     - SCSI Manager (old-style) emulation
41     - Emulates extended ADB keyboard and 3-button mouse
42 cebix 1.15 - Uses UAE 68k emulation or (under AmigaOS and NetBSD/m68k) real 68k
43     processor
44 cebix 1.1
45     %prep
46 cebix 1.13 %setup -q
47 cebix 1.1
48     %build
49     cd src/Unix
50 cebix 1.14 CFLAGS=${RPM_OPT_FLAGS} CXXFLAGS=${RPM_OPT_FLAGS} ./configure --prefix=%{_prefix} --mandir=%{_mandir}
51 cebix 1.13 if [ -x /usr/bin/getconf ] ; then
52     NCPU=$(/usr/bin/getconf _NPROCESSORS_ONLN)
53     if [ $NCPU -eq 0 ] ; then
54     NCPU=1
55     fi
56     else
57     NCPU=1
58 cebix 1.10 fi
59 cebix 1.13 PARL=$[ $NCPU + 1 ]
60     make -j $PARL
61 cebix 1.1
62     %install
63 cebix 1.13 rm -rf ${RPM_BUILD_ROOT}
64 cebix 1.2 cd src/Unix
65 cebix 1.14 make DESTDIR=${RPM_BUILD_ROOT} install
66 cebix 1.10
67     %clean
68 cebix 1.13 rm -rf ${RPM_BUILD_ROOT}
69 cebix 1.1
70     %files
71 cebix 1.13 %defattr(-,root,root)
72 cebix 1.3 %doc ChangeLog COPYING INSTALL README TECH TODO
73 cebix 1.13 %{_bindir}/BasiliskII
74 cebix 1.17 %{_mandir}/man1/BasiliskII.1*
75 cebix 1.16 %config %{_datadir}/BasiliskII/keycodes
76     %config %{_datadir}/BasiliskII/fbdevices