ViewVC Help
View File | Revision Log | Show Annotations | Revision Graph | Root Listing
root/cebix/BasiliskII/BasiliskII.spec
Revision: 1.13
Committed: 2000-10-05T17:24:47Z (23 years, 6 months ago) by cebix
Branch: MAIN
Changes since 1.12: +35 -31 lines
Log Message:
added RPM spec file

File Contents

# User Rev Content
1 cebix 1.13 %define name BasiliskII
2     %define version 0.8
3     %define release 1
4    
5     Summary: Free, portable 68k Macintosh emulator
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}
9 cebix 1.1 Copyright: GPL
10 cebix 1.10 Group: Applications/Emulators
11 cebix 1.13 Source: %{name}_src_05102000.tar.gz
12 cebix 1.10 URL: http://www.uni-mainz.de/~bauec002/B2Main.html
13 cebix 1.13 BuildRoot: %{_tmppath}/%{name}-root
14     Prefix: %{_prefix}
15 cebix 1.1
16     %description
17 cebix 1.13 Basilisk II is a free, portable, Open Source 68k Macintosh emulator. It
18     requires a copy of a Mac ROM and a copy of MacOS to run. Basilisk II is
19     freeware and distributed under the GNU General Public License.
20 cebix 1.1
21     Some features of Basilisk II:
22     - Emulates either a Mac Classic (which runs MacOS 0.x thru 7.5)
23     or a Mac II series machine (which runs MacOS 7.x, 8.0 and 8.1),
24     depending on the ROM being used
25     - Color video display
26     - CD quality sound output
27     - Floppy disk driver (only 1.44MB disks supported)
28     - Driver for HFS partitions and hardfiles
29     - CD-ROM driver with basic audio functions
30 cebix 1.8 - Easy file exchange with the host OS via a "Host Directory Tree" icon
31     on the Mac desktop
32 cebix 1.1 - Ethernet driver
33     - Serial drivers
34     - SCSI Manager (old-style) emulation
35     - Emulates extended ADB keyboard and 3-button mouse
36     - Uses UAE 68k emulation or (under AmigaOS) real 68k processor
37    
38     %prep
39 cebix 1.13 %setup -q
40 cebix 1.1
41     %build
42     cd src/Unix
43 cebix 1.13 ./configure --prefix=%{_prefix}
44     if [ -x /usr/bin/getconf ] ; then
45     NCPU=$(/usr/bin/getconf _NPROCESSORS_ONLN)
46     if [ $NCPU -eq 0 ] ; then
47     NCPU=1
48     fi
49     else
50     NCPU=1
51 cebix 1.10 fi
52 cebix 1.13 PARL=$[ $NCPU + 1 ]
53     make -j $PARL
54 cebix 1.1
55     %install
56 cebix 1.13 rm -rf ${RPM_BUILD_ROOT}
57 cebix 1.2 cd src/Unix
58 cebix 1.13 make prefix=%{_prefix} DESTDIR=${RPM_BUILD_ROOT} install
59 cebix 1.10
60     %clean
61 cebix 1.13 rm -rf ${RPM_BUILD_ROOT}
62 cebix 1.1
63     %files
64 cebix 1.13 %defattr(-,root,root)
65 cebix 1.3 %doc ChangeLog COPYING INSTALL README TECH TODO
66 cebix 1.13 %{_bindir}/BasiliskII
67     %{_mandir}/man1/BasiliskII.1
68     %{_datadir}/BasiliskII/keycodes
69     %{_datadir}/BasiliskII/fbdevices
70    
71     %changelog