ViewVC Help
View File | Revision Log | Show Annotations | Revision Graph | Root Listing
root/cebix/BasiliskII/BasiliskII.spec
Revision: 1.15
Committed: 2000-10-10T21:14:21Z (23 years, 6 months ago) by cebix
Branch: MAIN
Changes since 1.14: +8 -6 lines
Log Message:
updated docs

File Contents

# User Rev Content
1 cebix 1.13 %define name BasiliskII
2     %define version 0.8
3     %define release 1
4    
5 cebix 1.15 Summary: 68k Macintosh emulator
6 cebix 1.13 Name: %{name}
7     Version: %{version}
8     Release: %{release}
9 cebix 1.1 Copyright: GPL
10 cebix 1.10 Group: Applications/Emulators
11 cebix 1.15 Source: %{name}_src_10102000.tar.gz
12 cebix 1.10 URL: http://www.uni-mainz.de/~bauec002/B2Main.html
13 cebix 1.13 BuildRoot: %{_tmppath}/%{name}-root
14     Prefix: %{_prefix}
15 cebix 1.1
16     %description
17 cebix 1.15 Basilisk II is an Open Source 68k Macintosh emulator. That is, it enables
18     you to run 68k MacOS software on you computer, even if you are using a
19     different operating system. However, you still need a copy of MacOS and
20     a Macintosh ROM image to use Basilisk II.
21 cebix 1.1
22     Some features of Basilisk II:
23     - Emulates either a Mac Classic (which runs MacOS 0.x thru 7.5)
24     or a Mac II series machine (which runs MacOS 7.x, 8.0 and 8.1),
25     depending on the ROM being used
26     - Color video display
27     - CD quality sound output
28     - Floppy disk driver (only 1.44MB disks supported)
29     - Driver for HFS partitions and hardfiles
30     - CD-ROM driver with basic audio functions
31 cebix 1.8 - Easy file exchange with the host OS via a "Host Directory Tree" icon
32     on the Mac desktop
33 cebix 1.1 - Ethernet driver
34     - Serial drivers
35     - SCSI Manager (old-style) emulation
36     - Emulates extended ADB keyboard and 3-button mouse
37 cebix 1.15 - Uses UAE 68k emulation or (under AmigaOS and NetBSD/m68k) real 68k
38     processor
39 cebix 1.1
40     %prep
41 cebix 1.13 %setup -q
42 cebix 1.1
43     %build
44     cd src/Unix
45 cebix 1.14 CFLAGS=${RPM_OPT_FLAGS} CXXFLAGS=${RPM_OPT_FLAGS} ./configure --prefix=%{_prefix} --mandir=%{_mandir}
46 cebix 1.13 if [ -x /usr/bin/getconf ] ; then
47     NCPU=$(/usr/bin/getconf _NPROCESSORS_ONLN)
48     if [ $NCPU -eq 0 ] ; then
49     NCPU=1
50     fi
51     else
52     NCPU=1
53 cebix 1.10 fi
54 cebix 1.13 PARL=$[ $NCPU + 1 ]
55     make -j $PARL
56 cebix 1.1
57     %install
58 cebix 1.13 rm -rf ${RPM_BUILD_ROOT}
59 cebix 1.2 cd src/Unix
60 cebix 1.14 make DESTDIR=${RPM_BUILD_ROOT} install
61 cebix 1.10
62     %clean
63 cebix 1.13 rm -rf ${RPM_BUILD_ROOT}
64 cebix 1.1
65     %files
66 cebix 1.13 %defattr(-,root,root)
67 cebix 1.3 %doc ChangeLog COPYING INSTALL README TECH TODO
68 cebix 1.13 %{_bindir}/BasiliskII
69     %{_mandir}/man1/BasiliskII.1
70     %{_datadir}/BasiliskII/keycodes
71     %{_datadir}/BasiliskII/fbdevices